Results 1 to 3 of 3

Thread: Center Drive Shaft Support issues

  1. #1
    Registered User
    Join Date
    Apr 2019
    Location
    Annapolis, MD
    Posts
    206

    Center Drive Shaft Support issues

    Hi All,
    Many of you may have seen my post about a highway shimmy that I've been having. It is intermittent and mainly at higher speeds, both under power and coasting, then it suddenly goes away again. First issue that I had was DRC fluid from my blown front soft line that got on the brake pad and made a mucky paste out of the brake dust making the brakes pulse randomly, but pretty hard under highway conditions...that has been cleaned up and the DRC has been replaced with new springs and Bilsteins...

    After fixing the brake pulse, I've still been getting a shimmy at highway speeds that come and go both at coast and under load. Since my car got a new Milltek exhaust for Christmas, it was the perfect time to check the center drive shaft support...video attached below...lots and lots of play in this...I'm assuming that this is not good. I see that 034 sells the center replacement and I'll need to get or fabricate a driveshaft support tool for alignment if I replace the carrier.

    Just confirming that this is totally shot before I replace unnecessary stuff...Thanks for your input!

    http://www.fototime.com/29451F3D4E4B9F1/orig.mov
    Last edited by Muggy; December 26th, 2019 at 21:30.

  2. #2
    Registered User
    Join Date
    Oct 2018
    Location
    MN
    Posts
    35
    That looks about how mine did and I had the same symptoms. https://www.youtube.com/watch?v=4iCll3kB1Lk

    While you have your driveshaft out, check the CV joints as well. On mine, one race and ball were completely shot. I didn't feel like getting new parts at the time, so I was able to move around the races and the ball so that there wasn't any two bad parts next to each other. It's held up surprisingly well for 5k miles. I think I'm just starting to feel it go bad again.

  3. #3
    Registered User
    Join Date
    Apr 2019
    Location
    Annapolis, MD
    Posts
    206
    Thanks...hope I'm on the right track...just got the 034 carrier today...seems pretty pliable too. I did order the center carrier, both CV's and new boots...figured I might as well do the entire shaft at the same time. Hoping that maybe the bearing is giving out on the carrier...I like to find a reason for my issues, not just guess and hope.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •