Results 1 to 13 of 13

Thread: Wet Driver's Side A-Pillar... Help Wanted!

  1. #1
    Registered User
    Join Date
    Sep 2019
    Posts
    53

    Wet Driver's Side A-Pillar... Help Wanted!

    After a search on the forum (via Google, not the integrated site search) I didn't see anything specific to this... Here are the facts:

    - I've owned the car a month and it's been kept out of the rain.
    - Today I picked up my car from the body shop after they reattached some door molding (unrelated to the windshield).
    - They did a quick wash (the only source of water recently) and the driver's A-pillar was freshly saturated afterwards.
    - I checked the left sunroof drain (trimmer line went straight through and came out totally clean -- I also can't imagine getting enough water in the sunroof seal from a quick wash like that for the sunroof drain to be a potential source).

    Based on the way the water was propagating it seems like it would be coming from behind the windshield along the left vertical edge -- wetness was concentrated on the "middle" of the A-pillar, not confined to the top or bottom. Could it be entering a bad windshield seal after running down the circled channel? Is there anything else behind there that might need addressing once the windshield comes out and before a new one goes in?



    The moisture was concentrated along the oval-circled section of the A-pillar.



    But then a well-recommended windshield shop says it's very rare for a windshield to just "suddenly start leaking" (though I have no way of knowing how long it has been leaking as a new owner). They say, "we'll replace your windshield and guarantee it doesn't leak, but that doesn't guarantee the car won't leak in general." Of course, that's fair.

    Suggestions welcome! The windshield is pretty blasted anyway so I could replace it, I just want to be sure I don't go after the wrong thing for no reason. Thank you for any help!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2044.jpg 
Views:	73 
Size:	42.3 KB 
ID:	19041   Click image for larger version. 

Name:	IMG_2045.jpg 
Views:	73 
Size:	33.6 KB 
ID:	19042  

  2. #2
    Registered User hahnmgh63's Avatar
    Join Date
    Feb 2007
    Location
    Roy, WA
    Posts
    3,079
    2003 White RS6 2013 Midnight Blue S5
    2013 Daytona RS5 2x944 Turbo's 1974 911 w/'91 3.6ltr motor
    Roy, WA

  3. #3
    Registered User
    Join Date
    Sep 2019
    Posts
    53
    Quote Originally Posted by hahnmgh63 View Post
    Thanks! I did check the forward sunroof drain, and it seemed clear. Can it be cracked and leaking inside the tube that runs down the A-pillar?

  4. #4
    Registered User
    Join Date
    Sep 2019
    Posts
    53
    I’m seeing the primary possibilities:
    1) Cracked drain assembly (requires headliner removal? )
    2) Cracked roof weld (in the channel, body shop repair with epoxy)

    Would be grateful to hear from anyone who’s had and solved the issue!

  5. #5
    Registered User
    Join Date
    Jul 2008
    Location
    Out there
    Posts
    7,711
    Take the molding off and perform a closer inspection

    do you hear and wind noises at high speeds

  6. #6
    Registered User hahnmgh63's Avatar
    Join Date
    Feb 2007
    Location
    Roy, WA
    Posts
    3,079
    What DHall1 said, you definitely need the molding off for further inspection. I doubt the drain would crack unless someone poked something into it if they had the trim off earlier. Possibly roof weld but I'd go with drain or windshield first.
    Pull the trim off and sit inside while someone sprays the windshield with water, have them start low and slowly work there way up the pillar towards the top and onto the sunroof.
    2003 White RS6 2013 Midnight Blue S5
    2013 Daytona RS5 2x944 Turbo's 1974 911 w/'91 3.6ltr motor
    Roy, WA

  7. #7
    Registered User
    Join Date
    Sep 2019
    Posts
    4
    I would suggest taking the A pillar cover off and while you're inside the car have someone hose that side of the car while you look for water leaks

  8. #8
    Registered User
    Join Date
    Sep 2019
    Posts
    53
    Quote Originally Posted by DHall1 View Post
    Take the molding off and perform a closer inspection

    do you hear and wind noises at high speeds
    Sage advice, and as a matter of fact, yes I do hear wind noise... see, they don't tell newbies what you can pull off (molding) and what you can't... Guess we found the source, thanks for the insight! Thanks, Audi, for steel rivets...



    Already have a body shop working up the quote... Then naturally picked up my first CEL on the way home. Made it just over 1,000 miles since purchase...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2055.jpg 
Views:	57 
Size:	45.6 KB 
ID:	19044  

  9. #9
    Registered User
    Join Date
    Sep 2019
    Posts
    53
    Many thanks to all who replied as well! One of the aspects that made prospective ownership tenable was the vast repository of experience contained herein...

  10. #10
    Registered User PCMacDr's Avatar
    Join Date
    Dec 2014
    Location
    San Fernando
    Posts
    123
    So, those Moldings just pull off ?

    Easy or what ?

    Do you have to put adhesive on it to place it back ?

    I am getting some water on passenger side and I have checked, Sunroof, cleaned out drainage area ( under the Coolant Res )

    thx for sharing
    2003 Audi RS6
    Daytona Grey
    APR EMCS

  11. #11
    Registered User
    Join Date
    Sep 2019
    Posts
    53
    Quote Originally Posted by PCMacDr View Post
    So, those Moldings just pull off ?

    Easy or what ?

    Do you have to put adhesive on it to place it back ?

    I am getting some water on passenger side and I have checked, Sunroof, cleaned out drainage area ( under the Coolant Res )

    thx for sharing
    It seemed pretty easy... I don't make a habit of just pulling on things until they just pop off, but the service manager at my trusted body shop was very confident as he pulled it away (carefully) at the top (enough to see underneath). Doesn't have adhesive but rather held in place with friction, and it re-seated fine. We didn't remove it all the way, just enough to verify that it's definitely rusted through underneath and the cause of the leaking. There's 15 years of dirt/dust/debris behind the strip, which I'm sure collected water and allowed it to sit on the rivets.

    Seems like if the strip got damaged (or wouldn't stay when reinstalled) there are cheap-ish options to replace: https://www.ebay.com/itm/2000-2001-2...L/143402854578

  12. #12
    Registered User PCMacDr's Avatar
    Join Date
    Dec 2014
    Location
    San Fernando
    Posts
    123
    thank you kindly for the detailed explanation

    Will tackle this once its stops raining here in Cali ( much needed )
    2003 Audi RS6
    Daytona Grey
    APR EMCS

  13. #13
    Registered User
    Join Date
    Sep 2019
    Posts
    53
    Quote Originally Posted by PCMacDr View Post
    thank you kindly for the detailed explanation

    Will tackle this once its stops raining here in Cali ( much needed )
    Absolutely! I plan on asking the body shop for some in-process photos, so if they come through with that I'll post showing the repair.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •