Page 2 of 2 FirstFirst 12
Results 19 to 25 of 25

Thread: Upgrading the Stereo of a 2003 RS6

  1. #19
    Registered User Other_Erik's Avatar
    Join Date
    May 2013
    Location
    Northern Virginia
    Posts
    852
    Quote Originally Posted by cch View Post
    OK. Me too. You once sent me some of the info, but never the contact details. I might surprise my wife with this at some point.
    Quote Originally Posted by snakebitte View Post
    I've been thinking about upgrading my non navi unit for a while to get the nav and blue tooth phone capability. could you send me the contact info please.
    PM Inbound to both of you

    O_E
    #905530 - Brilliant Black on Ebony. Sorted, running strong, ready for a new owner.
    No, I am not the board admin - that's Erik (from Sweden), I'm Other_Erik (from the US)

  2. #20
    Registered User live.marc's Avatar
    Join Date
    Apr 2015
    Location
    UK West Midlands
    Posts
    11
    Quote Originally Posted by Other_Erik View Post
    If you're like a lot of us, and prefer going with Audi OE equipment, Zawa can fit you out with an RNS-E Nav+ with a Bluetooth adapter for a lot less than you might think. Once you hear the audio quality (in comparison to the stock system), you'll be convinced

    PM incoming

    O_E
    Thanks for the reply, not sure about the RNS-E thinking i want an up to date system, not too concerned with stock look providing it still looks good. :-)

  3. #21
    Registered User Avus-RS6's Avatar
    Join Date
    Jan 2007
    Location
    Kirkland, WA
    Posts
    384
    Quote Originally Posted by 4everRS View Post
    Upgrading the stereo? You mean exhaust work, right?.....
    Exactly!
    2001 S4 Avant 6mt: AMD tuned, Stasis Streetsports.
    2003 RS6 Sedan 6mt: AMD tuned, 515awhp/635awtq, PSS9's, 4:1 Diff
    2006 Carrera S 6mt: EvoMS tuned, Sharkwerkes Exhaust, Numeric shifter, Fuchs Reps

  4. #22
    Registered User
    Join Date
    Oct 2015
    Posts
    12
    I was in the same situation a few months ago with my new to me RS6. Looked at going the RNS-E route, but ended up with the Pioneer AVIC-6100NEX. Very nice unit and with the trim plate for an A6 the installation looks very professional. Tried using the shark fin antenna, but was getting quite a bit of noise through the Sat antenna as well as lots of cutting in and out. Bottom line is that I put both the GPS and SAT antennas that were included in the kit on the front dash, and since my dash is black, and they are both very small, they don't stand out at all. If I ever decide to sell the car, it will be fairly easy going back to stock. I'll try and post some photos in the future.

    The sound through the stock speakers is quite nice and the Bluetooth connectivity for my Droid Turbo is seamless. Great upgrade.

  5. #23
    Registered User gregoryindiana's Avatar
    Join Date
    Apr 2003
    Location
    Indiana !!! USA
    Posts
    265
    I have sent you (Other_Erik) a PM. Thanks!
    2003 RS6, Mugello/Silver, MTM Stage 1 ECM, and TCM mod, Abt 19 inch wheels for summer, stock 18s for winter, RS6+ Pedals INSTALLED! 2Bennett coilover system, 2Bennett front brakes; DRC gone!

  6. #24
    Registered User Other_Erik's Avatar
    Join Date
    May 2013
    Location
    Northern Virginia
    Posts
    852
    Quote Originally Posted by gregoryindiana View Post
    I have sent you (Other_Erik) a PM. Thanks!
    And answered. Thanks and enjoy!

    O_E
    #905530 - Brilliant Black on Ebony. Sorted, running strong, ready for a new owner.
    No, I am not the board admin - that's Erik (from Sweden), I'm Other_Erik (from the US)

  7. #25
    Registered User live.marc's Avatar
    Join Date
    Apr 2015
    Location
    UK West Midlands
    Posts
    11
    In the end I upgraded with an aftermarket Pioneer AVIC F70DAB, and installed a back up camera, still works with the factory amp and subwoofers and sounds brilliant.

    I am getting a problem with my rear brake lights now though! Not sure if it's related to me taking out the old Sat nav and CD changer completely, or the rearview camera splicing into the reverse lights??? Problem is only when I turn my lights on, and then I get a brake warning light, and i lose power momentarily. Bit scary at first.

    But the warning chime is the worst, as it's every 30 seconds or so!

    Anyone had this before or have any knowledge in fixes?

    Cheers, stay safe.
    2003 Audi RS6 C5 Avant Black with 19's

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •